
Basically we want to take a hand drawn image and convert it to a 3D object.

We're going to show two different examples, using the following pictures:

Both pictures were simply scanned and then cleaned up in Gimp to remove any unwanted marks, etc.
I'd recommend first downloading the above two images and working through this tutorial
before scanning in your own images.  Just remember that your images should be able to be
recreated with lines that completely connect to one another.  In other words, you have to
make sure that your image creates a "solid" object and doesn't have gaps in it's lines, if
it does, clean it up in Gimp.

Now let's first start with the hotrod image, open up Inkscape, and then goto File->Open
and open the hotrod.png file and when prompted for "link or embed image", choose "embed"
and click "OK".

Now let's convert the image to a scalable vector graphic, so click and select the hotrod
image on the screen, then goto Path->Trace Bitmap...  Under the "Mode" tab, select
"Grays" and change "Scans" to "2", and make sure "Smooth" and "Stack scans"
are all checked, then click "Update" to see a preview of how the trace will look.  So long as
it looks similiar to the below screenshot, then click "OK" (once) and then close the dialog
box:

Inkscape just created a scalable vector of your image on top of your existing image.
Click and select the image if it's not already selected and press your right arrow key on
the keyboard 10 to 20 times to move the scalable vector graphic over to the right a little.
You should now be able to see your original image, try and click on it once to highlight
it and then press the "Delete" key on your keyboard to delete it.  Now reselect the vector
graphic and press the left arrow key on your keyboard the same number of times you move the
image to the right, so that it's back to it's original position.

So now we have a scalable vector graphic of the hotrod, but there's some problems with it,
right click on it and select "Ungroup", you should now see two dotted boxes, one is around
the hotrod and the other is around a white area, that's actually the background of the image
which we don't want.  (NOTE: During the Trace Bitmap... there was an option in there to
"Remove background" which we could have used, but didn't).  First click somewhere outside of
the picture to unselect everything, now try clicking the hotrod and then the white area,
you'll see that it's two different objects, so select the white area and press "Delete" on
the keyboard to remove it.

Now we have just the hotrod itself, however we don't want it filled in, we just want the
outline of it, so select the hotrod, then right-click and from the popup menu, select
"Fill and Stroke".  On the "Fill" tab select "no paint" (X) and on the "Stroke paint"
tab select the "Flat color" and then close the fill an stroke dialog.  You should now
have an image that looks like this:

Now save that file has an SVG by going to File->Save As... and saving the file as
"hotrod.svg".  Now for this tutorial, we don't really
care about the size of the 3D object, however if you wanted this object to be a
specific size, now is the time to adjust the size.  If you select the hotrod, then at
the top of the screen you'll see a "W" and "H" text boxes where you can set the size
of your image, just make sure to change the units from "px" (pixel) to "mm" (millimeter)
and make the image whatever size you want and then save it.  Again, for this tutorial



we're not going to care about it's size, so you can leave it at it's default size.

Now it's time to close Inkscape and fire up FreeCAD.

Once inside of FreeCAD, switch to the "Draft" workbench then goto File->New to
start a new project.  Then goto File->Import... and open the hotrod.svg file and
when prompted choose to import the "SVG as geometry (importSVG)" and click "Select".
You should now see an outline of your hotrod on the screen, like so:

Now we need to click on the "Model" tab in the "Combo View" area on the left and
you'll see a number of "path#####" entries listed, we need to convert each "path"
to a "face", and we do this by selecting each path (one at a time) from the list
and clicking the "Draft Upgrade" tool (you can find it under the Draft menu, or
the big arrow pointing up in the toolbar menu).  Once you've converted each path
to a face, you should have something that looks like this now:

Now we need to use the "Draft Downgrade" tool to remove some of the faces from
the hotrod to cutout the pieces we don't want.  To do this you need to first
identify which face is the main outline of the hotrod, which in my case was
actually called "Face" in the list and the rest with numbers were the other
pieces.  First select the "Face" from the list and then hold the "Ctrl" key down
on the keyboard and click one of the other faces in the list so that you have
two highlighted. (Extremely important: Order matters, you must first select the
main face and then the smaller piece to cutout, you can't do it the other way
around).  Once you have the two faces selected, now click the "Draft Downgrade"
tool (you can find it under the Draft menu, or the big arrow pointing down in
the toolbar menu).  You should see that the small face now got cut out of the
main face.  You will also now have a new "Cut" object in the list, this is the
new main object that you want to select first and then one of the other faces
and then do the "Draft Downgrade" again, which will give you a new "Cut###"
which you will select again along with one of the other faces and "Draft
Downgrade" again, and so on until you are left with just a "Cut###" object in
the list with your hotrod looking like this:



Now that we have our whole face cut properly, we are ready to extrude the
object to make it 3D.  Switch over to the "Part" workbench and select the
"Cut###" object in the list and then use the "Part Extrude" tool (from the
"Part" menu or the toolbar), in the "Tasks" tab that it brings you to, change
the "Length" from "1.00" to "10.00" (this number is in millimeters) and click
the "OK" button.  Now rotate the object a little and you should see that it's
now a 3D object:

That's it, you can modify the object how you like at this point, including
adding other primitive shapes to it and doing boolean operations (union,
intersection, difference, section) to modify your object.  Remember to save
your new model to something like hotrod.fcstd.

Now let's try and do the same thing with the apple image, but instead of
cutting out all of the pieces, we'll engrave them a little to show how
we can manipulate our 2D objects in FreeCAD.

First open up Inkscape again and then goto File->Open and open the apple.png file
and when prompted for "link or embed image", choose "embed" and click "OK".

Now let's convert the image to a scalable vector graphic, so click and select the apple
image on the screen, then goto Path->Trace Bitmap...  Under the "Mode" tab, select
"Grays" and change "Scans" to "2", and make sure "Smooth", "Stack scans" and also "Remove
background" are all checked, then click "Update" to see a preview of how the trace will
look.  So long as it looks similiar to the below screenshot, then click "OK" (once) and
then close the dialog box:



Inkscape just created a scalable vector of your image on top of your existing image.
Click and select the image if it's not already selected and press your right arrow key on
the keyboard 10 to 20 times to move the scalable vector graphic over to the right a little.
You should now be able to see your original image, try and click on it once to highlight
it and then press the "Delete" key on your keyboard to delete it.  Now reselect the vector
graphic and press the left arrow key on your keyboard the same number of times you move the
image to the right, so that it's back to it's original position.

So now we have a scalable vector graphic of the apple, since we selected the "Remove
background" option in the Trace Bitmap... dialog, you can see that if you right click on
the graphic, there is no "Ungroup" this time, because all we have is just the apple itself.
So we don't have to remove any background from this image manually.

We again, have to unfill the apple image so that we just have the outline of it, so
select the apple, then right-click and from the popup menu, select
"Fill and Stroke".  On the "Fill" tab select "no paint" (X) and on the "Stroke paint"
tab select the "Flat color" and then close the fill an stroke dialog.  You should now
have an image that looks like this:

You'll notice that there are two onlines around the image, we'll take care of that in
FreeCAD, for right now save the file as an SVG by going to File->Save As... and
saving the file as "apple.svg".  Again, if you wanted
to, now is the time to scale your image to a specific size before importing it into
FreeCAD.  We'll leave it at it's default size for this tutorial.

Now it's time to close Inkscape and fire up FreeCAD.

Once inside of FreeCAD, switch to the "Draft" workbench then goto File->New to
start a new project.  Then goto File->Import... and open the apple.svg file and
when prompted choose to import the "SVG as geometry (importSVG)" and click "Select".
You should now see an outline of your apple on the screen, like so:

Now we need to click on the "Model" tab in the "Combo View" area on the left and
you'll see a number of "path#####" entries listed.  We want to get rid of some
of the paths, because we don't need some of them, look at the below picture and
highlight and delete the selected paths by simply selecting them and press the
"Delete" button on your keyboard:



So that your model now looks like:

Now we need to convert each "path" to a "face", and we do this by selecting each
path (one at a time) from the list and clicking the "Draft Upgrade" tool (you
can find it under the Draft menu, or the big arrow pointing up in the toolbar
menu).  Once you've converted each path to a face, you should have something
that looks like this now:



Now this time, we want to engrave the features of the apple on the apple,
instead of cutting them out like we did with the hotrod.  So this time, let's
go right over to the "Part" workbench and extrude the main "Face" (the apple
itself).  Select the "Face" object in the list and use the "Part Extrude" tool
((from the "Part" menu or the toolbar), in the "Tasks" tab that it brings you
to, change the "Length" from "1.00" to "10.00" (this number is in millimeters)
and click the "OK" button.  Now this made the apple have some depth:

And now we need to raise (Z axis) the other two faces so first select one of
the other "Face###" face objects and and click the "Data" tab near the
"Property/value" area in the left pane and select "Placement" and click the
"..." to bring up the placement dialog box:



Now in the "Translation" area, change the "Z" value from "0" to "6" and then
scroll down in the window and click "OK".  That just moved our one small piece
up a little bit inside of the apple, so now while that face is still selected
use the "Part Extrude" tool and make it's "Length" "4", you should now see it
again in the model on the screen.
Now repeat the above process for the other "Face###" object and your screen
should look like:

Now we want to cut the small pieces from the apple, so select the "Extrude"
(which should be your main apple) and then press the "Ctrl" key and select
one of the other "Extrude###" pieces (in that order) and perform a "Cut"
boolean operation (from the Part->Boolean menu or from the toolbar) and
repeat the process for cutting out the other small piece, so that your apple
now looks like this when you rotate it a little and zoom in on the etched out
pieces:



That's it, you can modify the object how you like at this point, including
adding other primitive shapes to it and doing boolean operations (union,
intersection, difference, section) to modify your object.  Remember to save
your new model to something like apple.fcstd.


